Military Significant Others and Spouse Support - MilitarySOS.com
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Pur water filter help **Added Video of filter squirting me**

  1. Senior Member
    BiggyBiggs's Avatar
    BiggyBiggs is offline
    Senior Member
    Join Date
    Jun 2010
    Location
    Atlanta, GA
    Posts
    13,255
    #1

    Pur water filter help **Added Video of filter squirting me**

    Advertisements
    We have great water pressure here so I know that is not the issue. We got our Pur water filter in the states and when we first got it it worked great. After we changed the filter it wasn't as powerful of a spray coming out when you switch it to filter. Then we moved here and I forgot about it. I just put in a new filter and it's still just nearly trickling out, plus leaking from the cap. I can't figure out what I am doing wrong.

    It's the Pur filter that hooks on to your faucet, like this

  2. "If you don't like my attitude, quit talking to me"
    TrishAFSpouse's Avatar
    TrishAFSpouse is offline
    "If you don't like my attitude, quit talking to me"
    Join Date
    Jan 2011
    Location
    VA
    Posts
    12,308
    #2
    Do those even work in Germany?
    When we were there the faucets were even a different size and shape.
    It sounds like its not attached all the way or something. Or maybe something got into it during the move.
  3. MilitarySOS Jewel
    Ol' Grey Mare's Avatar
    Ol' Grey Mare is offline
    MilitarySOS Jewel
    Join Date
    Feb 2011
    Location
    Indiana
    Posts
    14,646
    #3
    Are you sure you are using the correct filter? That would be my first thought since you noticed the issue after a filter change. Have you looked at how it is all going together to make sure things are fitting correctly? Is it difficult for you to get the unit back together when you put in a cartridge?
    I would take the filter cartridge out and take the whole assembly off the faucet. Soak it in vinegar for at least an hour, rinse and inspect it. I would pay particular attention to the output area. It may be that some deposits have formed and are blocking the water from exiting -- the inflow is strong, there is nowhere for it to get out so it's leaking from anywhere it can to get out.
    We have that same filter, but have never had any issues with it - and we have horrible hard water here.
  4. Senior Member
    BiggyBiggs's Avatar
    BiggyBiggs is offline
    Senior Member
    Join Date
    Jun 2010
    Location
    Atlanta, GA
    Posts
    13,255
    #4
    Quote Originally Posted by TrishAFSpouse View Post
    Do those even work in Germany?
    When we were there the faucets were even a different size and shape.
    It sounds like its not attached all the way or something. Or maybe something got into it during the move.
    Yes, it comes with a bunch of different attachments to fit different size faucets. Plus, we had this issue right before we moved.
  5. MilitarySOS Jewel
    Ol' Grey Mare's Avatar
    Ol' Grey Mare is offline
    MilitarySOS Jewel
    Join Date
    Feb 2011
    Location
    Indiana
    Posts
    14,646
    #5
    How long had you had it before you noticed the problem? Was it on the first filter change or just a filter change when you noticed it starting?
  6. Don't ever settle for less than you deserve.
    LoveMikeyBear's Avatar
    LoveMikeyBear is offline
    Don't ever settle for less than you deserve.
    Join Date
    May 2010
    Location
    Clearwater, FL
    Posts
    25,417
    #6
    Have you changed the filter? Is the little rubber thing that helps attach the faucet cracked/damaged? Do you have the other rubber rings that came with it to see if replacing the old one helps?

    We had one that did the same thing no matter how much DH or I messed with it and DH is pretty good at figuring stuff like that out. Now we have a new water filter now that measures how many gallons if has filtered and I love it it's even nicer looking and doesn't just tinkle out water or spray it all over the dang place.

    This is the one now and it even came with different sized things to screw onto different faucets it's called "DuPont Deluxe Faucet Mount Water Filter, Chrome"
    Signature removed due to size.
  7. Senior Member
    BiggyBiggs's Avatar
    BiggyBiggs is offline
    Senior Member
    Join Date
    Jun 2010
    Location
    Atlanta, GA
    Posts
    13,255
    #7
    Quote Originally Posted by ZivaD View Post
    Are you sure you are using the correct filter? That would be my first thought since you noticed the issue after a filter change. Have you looked at how it is all going together to make sure things are fitting correctly? Is it difficult for you to get the unit back together when you put in a cartridge?
    I would take the filter cartridge out and take the whole assembly off the faucet. Soak it in vinegar for at least an hour, rinse and inspect it. I would pay particular attention to the output area. It may be that some deposits have formed and are blocking the water from exiting -- the inflow is strong, there is nowhere for it to get out so it's leaking from anywhere it can to get out.
    We have that same filter, but have never had any issues with it - and we have horrible hard water here.
    I don't think it's build up, it looks very clean and nearly brand new and if I take the filter out and let the water run directly on the hole, it comes shooting out just fine. I suppose it's possible I have the wrong filters, although at the same time it seems to fit fine. I dunno, the one thing I am noticing is that when I face the arrow toward the front like it says I screw on the cap the filter rotates inside.
  8. Senior Member
    BiggyBiggs's Avatar
    BiggyBiggs is offline
    Senior Member
    Join Date
    Jun 2010
    Location
    Atlanta, GA
    Posts
    13,255
    #8
    Quote Originally Posted by ZivaD View Post
    How long had you had it before you noticed the problem? Was it on the first filter change or just a filter change when you noticed it starting?
    First filter change. It's fairly new, this is only the second filter we've bought for it besides the one that came in it when we bought it - and thats the only time it's worked super well.
  9. Senior Member
    helloimkaley's Avatar
    helloimkaley is offline
    Senior Member
    Join Date
    Oct 2008
    Location
    Shunan, Japan
    Posts
    15,804
    #9
    With Pur there is only one type of filter to replace the existing one so I don't think that is the problem. Maybe you just aren't putting it in right. I don't know. I had one last year and never had an issue with it.
  10. Senior Member
    BiggyBiggs's Avatar
    BiggyBiggs is offline
    Senior Member
    Join Date
    Jun 2010
    Location
    Atlanta, GA
    Posts
    13,255
    #10
    Quote Originally Posted by helloimkaley View Post
    With Pur there is only one type of filter to replace the existing one so I don't think that is the problem. Maybe you just aren't putting it in right. I don't know. I had one last year and never had an issue with it.
    I dunno, maybe this calls for a video demonstration from me and then you all can tell me what I am doing wrong
Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •