I want to upgrade, but I cant use "new every 2".